Privacy 3.8.3 fails due to incorrect version of .Net Framework

Problem

After installation (or upgrade) of Privacy 3.8.3 the connection to the database fails despite correct connection-details.

This problem may point to the incorrect version of the .Net Framework.

Privacy requires .Net Framework 4.7.0 or higher.

You can check the version of your installed .Net Framework by opening a Powershell and providing the command: 

   Get-ChildItem 'HKLM:\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full\'

Check the output for the version.


Normally, If the version is below 4.7.0 ,Privacy installs this framework for you. It downloads the correct software , using the internet, from the Microsoft site.

(info) Customers installing software on machines without an internet connection on the machine installing the DATPROF Software on, may encounter problems.

Solution

The normal installation of DATPROF Privacy checks for the installed version of the .Net Framework and,  if a new version is required , it starts downloading a special installer for this.

This is done using : http://go.microsoft.com/fwlink/?LinkId=863262

Running the executable provided by the link  will download and install the correct .Net Framework for you.

(warning)Without an internet connection this will fail.


Microsoft also has an offline installer for you.

You can download this using: https://support.microsoft.com/en-us/help/4054530/microsoft-net-framework-4-7-2-offline-installer-for-windows

Download the software on a internet connected machine.

Then copy the downloaded software to the intended DATPROF Privacy machine and start the installer. It will install the Framework for you.